Jump to content

Onkyo 606 HDMI sometimes doesn't display


Recommended Posts

I have a Onkyo 606 receiever. I find that the HDMI input from PC using ATI Radeon 3650 sometimes doesn't display anything, you will get a no signal from the TV. After fiddling by switching to TV and other modes and back and forth, suddently the HDMI works. Anyone else face that problem and what might be the problem?

Link to comment
Share on other sites



thanks pete. i finally gave up because it takes me 10 mins to get the hdmi working each time I want to watch something.

 

I bought sound blaster x-fi surround 5.1 so i can have optical out to my onkyo 606. the hdmi goes direct to tv. now my onkyo is like a traditional audio reciever rather than an avr. at least I can watch immediately now! sigh, the promise of hdmi.

Link to comment
Share on other sites



i have no problems connecting to my friends onkyo 606/706/806/906 through a few pcs with igp ati 780/790 chipsets. i have even connected to them successfully with an older ati x1950 non-hdcp dvi-port using anydvd to comply with the hdmi/hdcp handshakes. suspect it is your graphic card that is at fault. i do remember when i switch modes it takes about a few seconds for the av-amp and the display to sync.

 

when you connect directly to the display do you have such problems? i know you have probably done it but just to ask have you upgraded to the latest ati driver also ;D

 

Link to comment
Share on other sites

  • 2 months later...

i get the intermittent hdmi input problem with my other inputs (mio tv, xbox,dvd) besides PC. So i have concluded it's the receiver problem and finally had the time to drop it at the service centre. It's really inconvenient place and takes a couple of days. Hopefully it returns working perfectly.

 

the below links describes exactly the problems i have been facing. anyone else locally having the same problems?

 

http://www.avsforum.com/avs-vb/showthread.php?t=1141824&page=3

Link to comment
Share on other sites

  • 1 month later...

after the capacitors are replaced by the distributor, the problem seemed to have disappeared. but i'm unhappy over the fact i am made to pay to replace parts that are faulty in the first place. the intermittent symptoms made me thought it was the cable or tv problem but it was the receiever's capacitors. oh well.. at least after some heartache and dollars spent, i have a working receiever again. hope it holds though.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.




×
×
  • Create New...
To Top