Jump to content
IGNORED

Help ..subwoofer problem


Recommended Posts

Hi, (this is my first posting in this forum)

 

I think I have a major problem with my subwoofer. It's giving out only cracking noise. I just moved my HT to a different place. My subwoofer is connected directly to the AC socket whereas my amplifier and player is connected to a voltage regulator (AVR). On numerous occasions the AVR gives this rapid switching sounds ... indicating the supply line voltage is not stable? ???Wonder if the fluctuating voltage could have damaged my subwoofer. (Subwoofer model is Infinity RS10). Appreciate any help. Thanks.

Link to comment
Share on other sites


This is the voltage regulator used for PC. In fact I was using it for PC, and I was trying it on my HT to see if there is any sound difference and also as a protection against voltage fluctuations.

 

Yes, I can connect my HT directly to the AC socket. I'm only using the AVR for my amp and player b'cos the power rating is not enough to include the subwoofer.

Link to comment
Share on other sites


Can I use the high-level output of the subwoofer for troubleshooting? I was thinking of connecting the high-level output to my rear speakers and hear what sound comes out. Can I get any output if the subwoofer level is zero? (b'cos the cracking noise is very loud even at very low level)...Thanks for the replies

Link to comment
Share on other sites


 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.




×
×
  • Create New...
To Top