Jump to content

EOI: Technics SL -10 not working


Recommended Posts

Item: EOI: Technics SL -10 not working
Location:  Brookvale
Price:  350 ONO
Item Condition: Good 
Reason for selling: No money to
 fix it
Payment Method: Pickup - Cash, Paypal, COD Only
Extra Info:

 I bought this when I was overseas as I have always wanted to own one. My technician has done some work on it and it powers on now but he said that more work is required and he doesn’t have time to fix it. The roadmap for my gear is :

- Upgrade my tonearm,

- Install my Ortofon Black on it

- [ Get some bookshelf’s speakers, there are some gorgeous pairs on the classifieds now ]
 

If anyone is keen to buy it please PM, I paid about 400 bucks but make an offer I won’t be offended.


Cosmetically I’ll say it’s 7 of 10 and it’s 240 so it will work here with no issues.
Photos: Advertisements without photos of the actual item will not be approved.

20EB9797-58F5-4EA0-BF36-8D8997F5EA5A.jpeg

EA3214B0-52F0-4867-81BB-6CDBC7B2C934.jpeg

77B20D70-F0C4-4598-AA5D-D372A8CBFA05.jpeg

4B64B25E-663F-4BAF-8EF9-9E8F041815AF.jpeg

Edited by hlov
Link to comment
Share on other sites



Thanks for the messages that I have received, I have found a technician that said that he has experience on these kind of turntables so I’ll take it to him for a proper review and then will decide what to do next.

H

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...
To Top