Jump to content

Lg 42le5510 Won't Connect To Network


Recommended Posts

My new LG TV that is supposed to have ethernet connectivity and DLNA is refusing to connect to my home network. On the back where the ethernet cable plugs in, there are a green steady light and a flickering amber light indicating that an ethernet connection is present.

My Netcomm NB9W ADSL router shows a light for that port.

On the TV screen in the Networking menu, there should be three items. these are Network Setting, Network Status and Legal Notice.The top two are greyed out and can't be selected. All of the information I've been able to find presupposes that I can select one of these two options.

I have tried enabling/disabling DHCP on the router. I have tried several different ports and several different cables. As far as I can tell, all MAC security and ip security on the router is off. A laptop plugged in to the same port with the same cable connects and gets an IP address.

I have tried unplugging all other devices except the TV.

In the Service menu, the network test function stops and says it is not connected. Software update won't work because there is no network connection. I went through all this with the LG customer service rep and he got the the end of his crib sheet with no resolution to the problem.

Frankly I've run out of things to try. Is there a hidden menu I can use to see if I've just been locked out of the settings by some nanny function?

Link to comment
Share on other sites



  • 1 month later...
My new LG TV that is supposed to have ethernet connectivity and DLNA is refusing to connect to my home network. On the back where the ethernet cable plugs in, there are a green steady light and a flickering amber light indicating that an ethernet connection is present.

Did you ever get this working? I read somewhere else that a firmware upgrade should fix it, but that seems contradictory since you need a network connection to be able do it yourself :) What Firmware do you have ? Mine is 03.03.02 but I haven't tried to connect the network yet. Would love to hear your experiences since your last post, particularly on any post-firmware upgrade issues/improvements you've noticed.

Link to comment
Share on other sites

  • 3 months later...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...
To Top