Jump to content
IGNORED

Swivel Causes Loss Of Signal


Recommended Posts

I have received my new Hitachi 42pd960 and very happy with picture and all but I have one problem. When I connect the Panel Swivel lead and do swivel the panel all channels that I try to tune into will show 'Weak Signal" . But when I take the swivel lead off it tunes in perfectly.

Have anyone had similar problem or does anyone know if I am doing something wrong. Thank you for any help/advice given.

Link to comment
Share on other sites



That kind of thing usually has something to do with the incoming aerial lead, like one side [braid or core] not connecting properly at the aerial or a plug/socket along the path, but more likely the braid side.

Link to comment
Share on other sites

I have received my new Hitachi 42pd960 and very happy with picture and all but I have one problem. When I connect the Panel Swivel lead and do swivel the panel all channels that I try to tune into will show 'Weak Signal" . But when I take the swivel lead off it tunes in perfectly.

Have anyone had similar problem or does anyone know if I am doing something wrong. Thank you for any help/advice given.

Don't listen to the idiot Madmax, clearly he has nothing constructive to add and has not seen or used the Hitachi swivel.

I have the motorised swivel on my 32 inch Hitacvhi LCD and it works PERFECTLY. Check around the back that the the two lead are connected properly and not tied around any other leads etc. Move the swivel and look at what it is doing at the back of the plasma and you should see if it is catching on anything.

Do you have a PVR or set top box. Wondering if it does the same thing on that?

Other than that give Hitachi a call

BTW, how does the picture etc look with HD FTA and foxtel?.

cheers

Link to comment
Share on other sites



Don't listen to the idiot Madmax, clearly he has nothing constructive to add and has not seen or used the Hitachi swivel.

I have the motorised swivel on my 32 inch Hitacvhi LCD and it works PERFECTLY. Check around the back that the the two lead are connected properly and not tied around any other leads etc. Move the swivel and look at what it is doing at the back of the plasma and you should see if it is catching on anything.

Do you have a PVR or set top box. Wondering if it does the same thing on that?

Other than that give Hitachi a call

BTW, how does the picture etc look with HD FTA and foxtel?.

cheers

I have checked all the above and everything seems to be ok. The problem is not really worrying me as where the TV is I do not need to use the swivel motion but you will never know whether I will need it in the future. I will give Hitachi a call tomorrow. I use the in built set top box. Also the picture look great on any HD reception. Overall very happy with it. Are you happy with your 32 inch LCD Hitachi?

Link to comment
Share on other sites

I have checked all the above and everything seems to be ok. The problem is not really worrying me as where the TV is I do not need to use the swivel motion but you will never know whether I will need it in the future. I will give Hitachi a call tomorrow. I use the in built set top box. Also the picture look great on any HD reception. Overall very happy with it. Are you happy with your 32 inch LCD Hitachi?

Yea the 32 inch LCD is very good. I have this in our bedroom, so looking for a replacement for my CRT screen in the lounge room.

Not sure whether to go 42 or 50 inch. Did you have to change the settings much on your PD960?? I have seen it in a couple of shops and the picture is a bit fuzzy?. The 50PD960 however looks very good.

The Pio has the best black, but really it does not seem worth the extra money. Surprisingly even the samsung looked quite good.

For me I think it may be between the pana and Hitachi - the hitachi has a better remore and easier to change the settings

Link to comment
Share on other sites

I got the 42PD960 on Friday and, although it's sitting on the floor of an empty loungeroom and I haven't had much time to fiddle with settings, it's looking very good. Had a quick flick at planet earth last night, but only some deep see vent shots which were a bit blurry anyway, so not totally blown away.

Setting up the full system this PM (will see how the SD Toppy goes), so I'll get back on my thoughts. Played around with some settings abut then didn't save them (grrrr), but still trying to work out how to delete channels from the internal tuner.

And, of course, a key reason the reason I bought (apart from the 1080 vertical at the price point) was that the bezel looks so much better than the pana - I showed my wife in-store and there were no questsions about buying the more expensive Hitachi.

Kent

Link to comment
Share on other sites

Problem Fixed. Got behind the unit and got my wife to swivel it and I made sure that no cables are pulling. There wasn't any. Then I thought I will change the coaxial cables as one of the earlier replies suggested that it could be the braid touching. There I realised that I bought a Power Surge protector board and the antenna lead goes fromm the wall socket to it and than from the board to the TV, I assume to protect it form lghting strikes. So I connected the antenna lead directly from the wall socket to the TV and the problem is solved. Hip Hip Hooray.

So it is not a poor design and I am not stuck with it. Sorry to disappoint you Madman.

I fiddled with the picture settings and I find that a) it is very much a matter of opinion how you like the picture settings, some like it sharper,or brighter etc. and :blink: it seems that different shows need slightly different settings. Now with the swivel motion fixed I cannot be happier with my new Hitachi 42pd960.

Thank you to everybody that offered any suggestions. (Except Madman of course, only joking).

Link to comment
Share on other sites



Problem Fixed. Got behind the unit and got my wife to swivel it and I made sure that no cables are pulling. There wasn't any. Then I thought I will change the coaxial cables as one of the earlier replies suggested that it could be the braid touching. There I realised that I bought a Power Surge protector board and the antenna lead goes fromm the wall socket to it and than from the board to the TV, I assume to protect it form lghting strikes. So I connected the antenna lead directly from the wall socket to the TV and the problem is solved. Hip Hip Hooray.

So it is not a poor design and I am not stuck with it. Sorry to disappoint you Madman.

I fiddled with the picture settings and I find that a) it is very much a matter of opinion how you like the picture settings, some like it sharper,or brighter etc. and :blink: it seems that different shows need slightly different settings. Now with the swivel motion fixed I cannot be happier with my new Hitachi 42pd960.

Thank you to everybody that offered any suggestions. (Except Madman of course, only joking).

Good to see the prob fixed

I boutght one of those so called surge protectors a while back, and you are right. They are absolute **** - riuned the PQ, so I took it back.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...
To Top