Jump to content

Wifi 802.11G woes with XP-SP2


Recommended Posts

When I was using XP Service pack 1 on the following PC's:

PC1 (Desktop) Pentium 4 2.4 Intel Springdale (no-brand self built)

DigiTV 3.12b3 + PCI Nebula Card

Belkin F5D7000au (PCI) (using built in XP wifi software)

PC2 (Notebook) Pentium 4 2.0 Toshiba TE2100

DigiTV 3.12b3

Intel 2200BG (MiniPCI) (using built in XP wifi software)

Streaming from PC1 to PC2 worked perfectly fine with SP1 (despite having to disable the 10/100 ethernet connection for wifi to work). Now with SP2 on both PC's, ive had major problems getting them to work smoothly even when both PC's are right next to eachover.

Senario 1: The notebook wont detect the wifi connection on the PC at all.

Senario 2: The notebook and PC will connect BUT digiTV on both PC's will just stumble to a halt for 10 seconds at a time - showing garbage for a split second, then pausing again etc...

Senario 3: The notebook would play for 1 second, then the next second would pause for two seconds, then play for 1 second, etc...

I thought it has a reception issue initially since it was dropping to only 1mbit/sec (from 54mbit/sec), and I was right. I moved the PC's antenna to its side, then it streamed PERFECTLY fine for about 2 minutes, then I closed DigiTV and re-opened it and it suddenly started to go bad again - and I didnt do or move anything else! But at least the speed stayed at 54mbit/s now.

For the next two hours - no matter what setting I tried or what position of the notebook or antenna, I cannot get a smooth stream :blink:

Note that when the PC's wifi antenna was in the original "bad" position when I had SP1, it had zero reception problems even when the notebook was 20 meters away.

Link to comment
Share on other sites



Hi HR, yes I have disabled the Firewall on both PC's. I have checked for updated drivers for both cards and there are no 2004 (when SP2 was released) drivers available.

The Belkin does have new newer 2003 drivers (from my currect 2002 drivers) which I will try tomorrow, but even so, it was working fine for those 2 minutes which led me to believe its probably not a driver issue.

Ive tried just about everything I could think of including rebooting, repairing and reinstalling both network connections, trying the belkin wifi utility instead of XP (which didnt work at all), tried different RTS/CTS settings and power usage/saving settings, trying DigiTV multicasting, trying static IP addresses, all to no avil :blink: And thanks to Microsofts policy of not catering for us "power users" and not giving us detailed information of what is actually happening in the background, it makes it extremely hard for me to diagnose the problem.

Link to comment
Share on other sites

Interesting Anarchi

Re: Service Pack 2 XP.

I note with Windows patch a new intergrated app for sercurity control.

The firewall seems to have trace orginator for the internet.

Knowing MS it would tend wack the server for a sixer in efficient throughput on WI-FI with penality.

I also note a new WI-FI applet Security (settings) now in the Control Panel.

These additional features maybe causing the grief your experiencing.

I am still waiting for the Belkin WI-FI Kit to arrive. My supplier promises and promises supply. :blink:

It is the 54MB WI-FI standard throughput. Eventually we'll compare notes as my setup will not be dissimular to your WI-FI setup using Nebula.

The upshot of this is I'll introducng Diploma Level Multimedia Students to DTV and the ramifications of it into the future in 2005 (March/April).

So I have meaningful vested interest in getting this WI-FI stuff working smoothly with Server side Nebula and client side Nebula software..

I'll be eventually sharing the courseware approach that I've taken to this and base it around the Nebula and DVICO DVB-T cards. Should be interesting.

I see a great future for some here to turn their hobby into meaningful income in their own various domains.

Regards

DA

Link to comment
Share on other sites

Hi DA, thanks for the info - I wouldnt be suprised if MS added some bloated security BS to the wifi interface. I didnt think to check the new Wifi/security settings in Control Panel so Ill have a look tonight. Though from what I remember, the wifi icon is just a n00b connection wizard.

I have the latest US Belkin v2.4.5 drivers (since the aussie drivers are only at v2.3) so Ill give that a go.

I think the difference between the US and Aus drivers is what channels they use, so it should work fine.

Link to comment
Share on other sites



Anarchi

Did you have multicasting on or was it unicasting ?

I had some strange results with network streaming under SP2 (over copper) and could only successfully get it to operate in multicasting mode

It worked fine for days like that. I still have a suspicion that it is MS related

Do your PC's stream OK over copper/Cat 5 ?

Link to comment
Share on other sites

Hi MT, you are right about multicasting - over copper 100MBit cable, Multicasting works fine, but uni-casting doesnt work at all (though I swear it was working a few days ago since I never use multicasting). I think Nebula should look into this issue with SP2 since I never had a prob with SP1.

Link to comment
Share on other sites

[edit] just when I thought the problem was solved (by moving the antenna)...

Yesterday (Wednesday) I moved the Belkin antenna towards the ground and it worked perfectly (2.5MB/sec) for hours. The next day however, I didnt move or change *anything*, all I did was reboot both PC's and now I'm having the same 150KB/sec problem :blink: Ive tried 360 antenna directions to no avil.

I have tried the belkin in another PC and it works perfect no matter where I point the antenna :confused:

Im quite baffled. I cant see how it could be an interference problem since it worked 100% perfectly with SP1 a month ago, and worked perfectly yesterday for 2 hours.

Any suggestions?

Link to comment
Share on other sites

HI Anarchi

The only thing I can think are two things:

1. Motherboard settings to EMI - ie spread sprectrum setting to curtail EMI emissions. Perhaps the broad spectrum settings was altered somehow in the BIOS.

Epox motherboard example in screen clip. Spread Spectrum setting.

http://www.3dnews.ru/documents/6147/bios_select_romsip.jpg

2. Power Supply has degraded and is now emitting EMI.

Regards

DA

Link to comment
Share on other sites

Hi DA, you could be right regarding EMI. My Nebula card is in the same pc and I have had strange intermittent reception issues with ABC even when the weather was fine, so its possible a component in the PC is intermittently being problematic. Though contrary to this theory, ABC at the moment is near perfect, yet the wifi is still bad. Who knows, maybe a component has a mind of its own and is emitting different EMI at different times :blink:

My Abit IS7 mobo doesnt have the ROMSIP setting, ill look into seeing if it has a similar setting, maybe under a different name. But even so, I have not changed any BIOS settings for months so I doubt its that.

I guess I just need to do some trial and error and unplug/remove each component/cable one by one. I have ruled out the belkin and software, it must be hardware.

[edit] thanks DA you got me thinking, I just remembered I have recently changed the video card from a GeForce256 to a GeForce 4 Ti4400, so maybe that has something to do with it...

Link to comment
Share on other sites



  • 3 weeks later...

Anarchi, I just stumbled upon this thread on the Sudhian forum.

The important thing is:

If you are running Windows XP, the Zero Wireless Configuration service checks the status of the wireless connection every minute, causing it to cut out. Simply disable the Zero Wireless Configuration service.

Setting up your wireless network with this disabled will be much less user-friendly, but this is the solution.

I dont know how this relates to your experience, but I hope it helps.

Link to comment
Share on other sites

Thanks for the link HR, I gave up trying to figure out the problem and now the Belkin has a new home in another PC which works fine. Ill try disabling the Zero Wireless Configuration when I get a chance to put the Belkin back in the DigiTV PC.

When I get my USB Nebula ill connect it to the good PC (currently with the Belkin) and see how that goes.

Link to comment
Share on other sites

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...
To Top