Jump to content

Rega TTPSU grounding buzz


Juicester
 Share

Recommended Posts

Anyone with a TTPSU done the grounding hack to eliminate a buzz? I noticed the buzz today and ran a wire from the ttpsu's 'supposed grounding wire' (which is connected to nothing with a ground!) to the grounding post in my phono stage and woila - buzz gone. The guy in this video might be a bit ott (love the part he apologised for having wind) - but I agree with him that it's ridiculous that Rega allowed this to leave the factory in its current state.

https://m.youtube.com/watch?v=CAY2rRsqHLE

Link to comment
Share on other sites

@@Juicester Yes definitely, the weird thing for me was that there was zero hum at all with the original Rega cartridge but was there when I fitted the Ortofon Blue 2M.

It must have something to do with the way the Rega cart is wired.

Edited by illusion
Link to comment
Share on other sites

I just notice it last night with mine.I accidentally had the power cable from the TTPSU under the tonearm and the buzzing was crazy. moving the cable around help but I will try this grounding link

  • Like 1
Link to comment
Share on other sites

I just notice it last night with mine.I accidentally had the power cable from the TTPSU under the tonearm and the buzzing was crazy. moving the cable around help but I will try this grounding link

Highly recommended. For a clean look, I removed the small screw from the back plate and ran a wire from the grounding point out the back of the case and then to my phono. You can't see it at all.
Link to comment
Share on other sites
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.




×
×
  • Create New...
To Top